LED not working

  • 524 Views
  • Last Post 13 March 2016
  • Topic Is Solved
okhenry posted this 27 January 2016

I just wrapped up my first Petduino build, and really my first attempt at soldering. When I first plugged in my Petduino the LED came on after a minute or so with all of the lights on. After uploading a sketch though i'm not getting any lights to come on. Is this just a soldering error somewhere or is there something else at play?

 

Thanks in advance,

 

Owen

5 Comments
Order By: Standard | Newest | Votes
Circuitbeard posted this 28 January 2016

Hi Owen,

It'd definately be a good idea to go back and inspect all the solder joints to make sure you don't have any bridged / broken connections. I'd also check that the screen has been put in the right way too.

Give those a try and see if they help and let me know if not and I'll we what we can suggest.

Cheers

Matt

okhenry posted this 29 January 2016

Hi Matt,

I went back and resoldered nearly everything since my technique improved a lot by the time i got the end, the new soldering iron and thinner guage solder certainly helped too. However, I'm still not getting anything to display on the LED screen. I double checked and the writing on the side of the LED is on the right side of board

I don't know if this helps any, but my petduino yells at me randomly. I currently have the monster sketch uploaded and it's the same sounds as if you were to hit button 2, except there is no button press. Didn't know if this was expected behavior, i didn't see anything in the code that looked like it would do that

 

Circuitbeard posted this 09 February 2016

Hi Own,

Really sorry for the delayed response. Didn't seem to get a notification of your reply for some reason.

That really does sound like a connection issue (we got a very similar issue this weekend which turned out to be one of the pins on the arduino nano wasn't soldered correctly) especially given it sounds like it's working apart from the screen.

Another thing worth checking is the chip for the LED matrix, making sure all the legs got seated correctly and didn't just get bent over when pushed into the IC socket.

Give it another double check and if it's it's still not working we can work something else out.

Sorry again for the delay.

Matt

okhenry posted this 13 March 2016

Hi Matt,

I know this is pretty old at this point, but I wanted to let you know that I was finally able to get everything working, Thanks for the help in getting my issue sorted out and for putting together such a great kit. Since putting this together I've been looking into more Arduino and Rasberry Pi projects and imagining what I could do with them, now I just have to find the time!

Thanks again,

Owen

Circuitbeard posted this 13 March 2016

Hey Own,

That's great news, so happy you managed to get it working and that it has inspired you to take your learning further. Do keep us up to date with whatever you work on, it's always nice to hear what people are up to.

Many thanks

Matt